Primer for SFVWatcher

Primer for SFVWatcher v.0.0.0.0

Until I have time to write proper documentation, this will serve to get beta-testers started with this product.

SFVWatcher is a simple application that watches for removable media drives (like CD-ROM drives). If media is inserted that has an .SFV CRC32 File Verification file in the root of the media, it verifies the files contained in the .SFV file against the data on the media.

This, of course, assumes you create a .SFV file and place it in the root of the volume before burning. This can be done for many directories with an application like Bitspring's HashMaker or on "directory at a time" basis with most any .SFV verification/creation programs, such as QuickSFV.

SFVWatcher was developed solely for use by the author and is not truly a "release" product. Therefore it lacks features the author considers important in a release product such as:

  • Multithreaded user-interface. Because the user-interface and worker operations are contained in the same thread, the SFVWatcher user-interface "freezes" when performing worker operations like calculating CRC32s.
  • Saving options to registry. No options will be saved between SFVWatcher sessions.

Most of SFVWatcher's features are self-explanatory and I will not go into them in this primer. Some, however, are not obvious and I will cover those topics here.

Watching the Drives

Watching the Drives

SFVWatcher makes use of a Windows API for watching removable media drives. If another application is using the same interface, it may disrupt SFVWatcher's operation. This is by design in the API to prevent conflicts. Most likely, the only effect will be the automatic ejection may fail if another program is watching that drive.