Primer for Bitspring Renamer

Primer for Bitspring Renamer v.0.1.263.0

Until I have time to write proper documentation, this will serve to get beta-testers started with this product.

Bitspring Renamer (BR) is a utility designed solely for batch renaming of files. BR does not rename directories and also does not support renaming according to file-specific information (i.e. MP3 tags). These features were intentionally left out as there are products already available for these purposes. While many of BR's features can be found in other renaming utilities, the package in general has some advanced features that, when coupled with the "common" features, allow for extremely flexible, powerful and unique renaming options.

Most of BR's features are self-explanatory and I will not go into them in this primer. Some, however, are not obvious and I will cover those topics here.

Adding files to the file list
Display Modes
Easy filling of the Replace field
Wildcards

Adding files to the file list

From Windows Explorer, select one or more files or directories and "drag-and-drop" them onto BR's main file list. If a directory is dropped, BR will recurse into the directory as many levels as are available.

Display Modes

BR has two display modes (DMs): Normal and Enhanced. Normal DM allows for much faster operation but is not as user friendly as Enhanced DM. When in Normal DM, the currently selected entry in the file list is displayed in the Sample edit box with the currently selected modifications. Therefore, in Normal DM, one can only see the potential output of the renaming options for a single file at a time. When in Enhanced DM, the file listing has two columns. On the left is the original file name. On the right is the file name as it will appear after renaming according to the selected options. While this is obviously a much easier interface, it is far slower as it has to calculate the modifications for every file instead of just one. Therefore when hundreds of files are in the listing, each change you make to the options results in a lag before they are displayed. When working with many files you may find it useful to enter the options while in Normal DM and then switch to Enhanced DM before renaming to verify that the results are what you expect for all the files.

Easy filling of the Replace field

Double clicking on a file in the file list will automatically copy the name to the Replace edit box.

Wildcards

The wildcard functionality is by far BR's most powerful and difficult to use feature. This feature is only applicable to String Replacement operations. When Allow Wildcards are turned on, case sensitivity is mandatory. Because I wanted to keep the syntax simple and yet unambiguous, I decided to create a new wildcard system that is composed of characters that are not allowed in FAT(32) & NTFS file systems. The two edit boxes that accept these wildcards are the Replace and With edit boxes. Some wildcards operate differently depending on which edit box contains them. The wildcards are as follows:

Replace

<c#> | Represents # characters
<d> or <n> | Represents any positive integer composed of any number of characters

With

<t> | The total number of files in the file list
<n> | The index of the file in the file list (which is sorted in ascending alphanumeric order)
<r#> | The text indicated by a Replace field. The # represents which Replace field's text to use. (e.g. If # = 2, then it would be the second <c#>, <d>, or <n> found in the Replace edit box

All three of the With wildcards can then be modified further when their text is a numeric value. These modifications are done by inserting a plus (+) or minus (-) before the ending angle bracket (>) followed by a specially formatted number. This number can modify the output in two ways. First, it can increment or decrement the value by any amount. Second, it can set the width of the output by inserting zeros (0) before the value to keep the number of digits equal to or above the assigned number of digits.

For incrementing or decrementing the value, follow the plus (+) or minus (-) with the amount that the value should be incremented (if using the plus) or decremented (if using the minus).

For formatting the output to use a certain minimum number of digits, follow the plus (+) or minus (-) with any number, including zero (0), made up of the preferred minimum of digits. (e.g. To set a minimum of four digits without modifying the value you would use '+0000')

Below I will include a good number of examples to demonstrate the usage of these wildcards. They will all be based on the following input file names being in the file list, with the output example based on the 2nd of the 4 files:

The Epic of Gilgamesh - Section1A.txt
The Epic of Gilgamesh - Section1B.txt
The Epic of Gilgamesh - Section2A.txt
The Epic of Gilgamesh - Section2B.txt
Replace | With | Output
Gilgamesh | Gilg | The Epic of Gilg - Section1B.txt
amesh |  | The Epic of Gilg - Section1B.txt
Gilg<c5> | Gilg | The Epic of Gilg - Section1B.txt
The Epic of Gilgamesh | Epic of Gilgamesh, The | Epic of Gilgamesh, The - Section1B.txt
<c4>Epic of Gilgamesh | Epic of Gilgamesh, <r1> | Epic of Gilgamesh, The - Section1B.txt
- Section<c2> | (<n> of <t>) | The Epic of Gilgamesh (2 of 4).txt
- Section<c2> | (<n+000> of <t+000>) | The Epic of Gilgamesh (002 of 004).txt
- Section<c2> | (<n-01> of <t+01>) | The Epic of Gilgamesh (01 of 05).txt
<c3><c1>Epic of Gilgamesh - Section<c2> | <r3> - Epic of Gilgamesh, <r1> | 1B - Epic of Gilgamesh, The.txt
<n><c1> | _<r1>-<r2> | The Epic of Gilgamesh - Section_1-B.txt